Plugin NextGEN Gallery macht WordPress-Seiten unsicher

Plugin NextGEN Gallery macht WordPress-Seiten unsicherKein CMS hat weltweit mehr Benutzer als WordPress, auf dem auch unser Blog allofus.de basiert. Eine Erweiterung (Plugin) kann jetzt allerdings durch mögliche SQL-Injection Probleme machen:

Die Sicherheitsforscher von Sucuri haben eine Sicherheitslücke im WordPress-Plugin NextGEN Gallery festgestellt. Wenn Angreifer die Schwachstelle ausnutzen, können sie mit SQL-Injection Code ausführen und so zum Beispiel Passwörter und Konfigurationsdaten abgreifen, warnt das Sicherheitsunternehmen. Das soll auch über das Netz und ohne Authentifizierung funktionieren.

Inzwischen haben die Entwickler des Plugins die Lücke in der aktuellen Version 2.1.79 schon geschlossen. Aktuell kann NextGEN Gallery über eine Million aktive Installationen vorweisen.

Wer noch eine verwundbare Version nutzt, ist aber nicht unter allen Umständen sofort gefährdet: Die SQL-Angriffe funktionieren den Sicherheitsforschern zufolge  in diesem Kontext nur, wenn die Funktion Basic TagCloud Gallery zum Einsatz kommt und wenn die Betreiber der Webseite erlauben, dass Benutzer Beiträge verfassen, die man bewerten kann.

Wenn das der Fall ist, können Angreifer zum Beispiel URLs manipulieren und aufgrund einer unzureichenden Überprüfung in gewissem Rahmen auch eigenen Code auf diese gefährdeten Webseiten aufbringen und ausführen.


wallpaper-1019588
Bild der Woche: Ringelnatter
wallpaper-1019588
Vereiert
wallpaper-1019588
Meditation für Geist und Seele
wallpaper-1019588
Es geht weiter mit den Coolen Blogbeiträgen der Woche!
wallpaper-1019588
Neuer Trailer zu Harry Potter Wizards Unite veröffentlicht
wallpaper-1019588
DIY Flammen Kürbis schnitzen
wallpaper-1019588
Samsung Galaxy S10: Drei Modelle scheinen geplant zu sein
wallpaper-1019588
Weniger ist mehr